こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

使用すべきOracle8i用JDBCドライバのバージョンについて

下記の構成でTomcatからデータソースを利用して
DBにJDBC接続しようと思っています。

【OS】
WindowsXP
【JDK】
1.4.15
【アプリケーションサーバ】
Tomcat4.1.36
【データベース】
Oracle8.1.5

Oracleインストール後、%ORACLE_HOME%/jdbc\lib/以下のフォルダには
下記のJDBCドライバしかありませんでした。

classes102.zip (JDK 1.0.2 用)
classes111.zip (JDK 1.1.x 用)

また下記のURLよりOracle JDBC Driver 8.1.5のJDBCドライバをダウンロードしようと試みました。

http://otn.oracle.co.jp/software/tech/java/jdbc/index.html

ところが、Oracle8iについては8.1.7のJDBCドライバのみ公開しており、
その内容を見ても下記のJDBCドライバしかありませんでした。

classes111.zip(JDK 1.1.x 用)
classes12.zip(JDK 1.2.x 用)

今回の私の環境では、どこからどのバージョンのJDBCドライバを入手して
使用すればいいのでしょうか?

ご教授よろしくお願いします。

投稿日時 - 2007-08-10 18:17:09

QNo.3244635

すぐに回答ほしいです

質問者が選んだベストアンサー

ORACLE社はMS嫌いなくせに、やってることはMSなみにあこぎなので(笑)
すでにOracle9i以前のものはサポート外になっています。
というわけで、classes12.zip以上のものがない以上、それを使うしかないでしょう。
どうせサポートされていないDBを使うわけですから、oracle10gのページから、
ojdbc14.jar をダウンロードしてみるのも手ですが、そんなことしなくても
classes12.zipをclasses12.jar にリネームすれば、問題なく使えると思いますよ。

投稿日時 - 2007-08-17 11:52:36

お礼

大変お礼が遅くなりました。
classes12.jarを使用して無事アクセスできました。
ありがとうございました。

投稿日時 - 2007-09-29 23:05:46

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問