こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

メモリの種類?チップの枚数

先日、168pin SDRAMのメモリ(256MB)を買いました。
両面実装なのですが、片面に8枚ずつのチップではなく、両面とも9枚のチップが付いています。びっくりして調べたのですが、これはサーバー用などに使われるECCという機能がある、言わば高品質だから9枚なのでしょうか。
また、これを使っても問題は無い・・宝の持ち腐れなだけで、デメリットは無いのでしょうか。

ECC機能付きのメモリと、ECC機能なしのメモリは混在できないなどという情報もあったのですが、元々ついていた片面実装8枚のメモリ(ECCはたぶんついていない)と混在してしまっています。一応、パソコンは2枚分の容量を認識しています。

このまま使っても何の問題も無いと考えて良いでしょうか。それとも9枚の1つにした方が良いのでしょうか。

投稿日時 - 2007-06-25 12:30:35

QNo.3114095

困ってます

質問者が選んだベストアンサー

おそらくパソコン側がECCに対応していないためECC機能を使用せずに動作していると思われます。動作しているのなら大丈夫だと思いますが、不安ならM/Bのマニュアルなり、メーカーのサポートなどから情報を取られた方が良いと思います。

参考URL:http://qa.buffalo.jp/eservice/esupport/consumer/esupport.asp?searchtype=normal&id=BUF2780

投稿日時 - 2007-06-25 13:49:04

お礼

メーカーのホームページではECC機能には対応して無いとありました。
ECCがついていてもマザーボードがECCをサポートしていなければ、ECCなしのメモリとして働くのですね。
一応動作はしてますが、このまま使っても取り合えず問題は無いと思って良いのでしょうか。さらに、ECCありの追加したメモリはPC133で、元々のECCなしはPC100なのですが、この組み合わせも、マズイという情報と、PC133がPC100に合わせて動くから大丈夫だ。という情報があり、困惑してます。
一緒に使うのは止めたほうが良いのでしょうか。

投稿日時 - 2007-06-26 20:28:46

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(6)

ANo.6

参考URL読みました。「細かな点が違う」というだけでは判断ができませんが、他にもhttp://www.atmarkit.co.jp/icd/root/75/12104475.html
などという解説もあるので違いがあるのは確かなようですね。

フリーズなどの問題があるのなら増設したメモリを疑うのは当然の流れですね。まず元のPC100のメモリ1枚に戻して問題がなくなるかを確認してください。問題なければ新しいメモリが原因と考えて良いと思います。
あと新しいPC133メモリ単独ではどうなるか、そもそもお使いのパソコンがPC133に対応しているかどうか、などもありますがそこまでやる場合にはまた質問をしてください。

投稿日時 - 2007-07-21 23:40:41

ANo.5

ちょっと誤解があるようです。
CL(CAS Latency)というのはデータを読み込むまでの「待ち時間」なのでCL2よりCL3の方が遅くなります。
参考:http://e-words.jp/w/CL.html

両方を使ったときにCL3動作になるということは遅い方に合わせている訳で問題はありません。遅いと言ってもナノ秒レベルの話なので実用上差が出ることは無いと思います。(何時間も掛かる処理をしない限り)

投稿日時 - 2007-07-14 13:15:38

お礼

何度もすみません、誤解してましたね。
CL3のほうが遅いんですね。
新しいメモリの方がPC133で速いので、てっきりこっちのCL3の方が速いのだと思いこんでました。
新しいメモリ:PC133(速い)けどCL3(遅い)
古いメモリ :PC100(遅い)けどCL2(速い)

ということもあるのですね。
色々気になっているのは、実は新しいメモリを増設してから、何となくフリーズしたり長い間反応が無くなる事が増えてる気がしたので、問題があるのでは?という先入観が少なからずあったのです。

もっともらしく、PC100とPC133を混ぜると不安定になるという解説も見かけたのですが、気にする必要は無く他の原因を考えた方が良いのでしょうか。
http://www.pc-view.net/word_id-0917.html

投稿日時 - 2007-07-21 17:34:56

ANo.4

お久しぶりです。まだすっきりしませんか。

> 起動時に自動的に検出・設定されるというのは、CL値が一つはCL3、
> もう一つがCL2となってるかもしれないし、両方CL2に合わせてくれて
> いるかもしれないと言うことでしょうか。

二つのメモリに対して個別に設定することは出来ません。どちらも動作する低い方の設定に合わされます。お使いのメモリがどういう仕様になっているか分かりませんが、PC133のチップがより遅い規格のPC100より劣ることは無いわけで、遅いクロックで動作する場合にはCL値も変わるのが普通です。PC133のときにCL3ということですが、これをPC100で動作させたときのCL値は別途決まっている筈です。もしそれがCL2ならどちらもCL2動作になりますし、最悪CL3のままならどちらもCL3になります。

BIOSで「CL値の変更も出来る筈です」と書きましたが、必ずしもそうではないようです。メーカー製のPCなら変更できない場合の方が多いかもしれません。例え変更できるとしても動作の安定のために遅くする(オーバークロックする場合など)のが目的で、メモリの規格以上に早くすることは出来ないので気にする必要はありません。要は現在の設定が確認できるかどうかですが、CPU-Zというフリーソフトがありますのでこちらを使う方が簡単かも知れません。有名なソフトですので検索ですぐに出てきます。
お試しあれ。

投稿日時 - 2007-07-11 08:46:15

お礼

CPU-Zというので見てみました。

CL2.0となってるかと思ったのですが、文字がかなり小さく見辛いのですが、3.0となっているようです。最悪、とありましたが、これはやはりCL2しかないメモリがCL3で頑張ろうとする分、よくないのでしょうか。

個別に設定することはできないのですね。それぞれ1枚にしてみて見ようかとも思ったのですが、古いメモリでやればCL2、新しいのでやればCL3と出るだけで意味無いでしょうね。

投稿日時 - 2007-07-13 20:41:14

ANo.3

メモリのCL値は普通はPC起動時に自動的に検出されて設定される筈です。心配ならBIOS画面で確認できると思います。BIOS画面の起動、およびそこに含まれるメニューや設定項目はパソコンによって違いますのでマニュアルを参照してください。

メーカー製パソコンではBIOSに関する説明が不足していることもありますが、メーカーのサポートサイトやインターネット検索で情報入手する必要があります。CL値の変更も出来る筈です。最悪、同種のBIOS(AWARD又はAMI)のマニュアルなどを参考にすることも出来ますが、メーカーのBIOSはカスタム化されていますので全てが同じわけではありません。下のリンクはDOS/V Power Reportという雑誌の最近の記事です。

Everestの解凍の問題は色々な原因が考えられます。フリーの解凍ソフトも色々ありますので他のソフトを試すのも手です。私は追加モジュール不要のLhacaを使っています。

参考URL:http://www.dosv.jp/other/0704/index.htm

投稿日時 - 2007-07-03 08:50:04

お礼

起動時に自動的に検出・設定されるというのは、CL値が一つはCL3、もう一つがCL2となってるかもしれないし、両方CL2に合わせてくれているかもしれないと言うことでしょうか。

そうなんです、メーカーではBIOSに関する情報は一切公開されてません。
どうやら、AMI WIN BIOSというBIOSらしいのですが、マニュアルが一切無く、検索しても見つけられずにいます。
増設後はずっと2枚ともついてるので、今度、256MB1枚にして見てしばらく使い、どっちが安定しているのかも試してみようと思っています。

投稿日時 - 2007-07-04 21:56:49

ANo.2

> メーカーのホームページではECC機能には対応して無いとありました

ということならECCの有無は関係ないですね。どっちもECC無しとしてしか認識されません。つまり大丈夫です。

PC133とPC100:
両方を一緒に使う、あるいはマザーボードがPC100までしか対応していない場合にはPC100の動作になります。速いクロックに対応可能な商品を遅いクロックで使うわけですから全く問題ありません。

投稿日時 - 2007-06-26 22:18:35

お礼

全く問題ないのですか。
調べてたらどうやらCL値が違うのは問題みたいですね。PC133とPC100を混ぜて不安定になったなんて書きこみも見たのですが、これはひょっとするとCL値が違ったのかもしれませんね。

新しく買ったメモリは、お店の袋にCL3と書かれているのですが、元からついてるメモリのチップを調べたらCL2らしいです。やはりこれはマズイのでしょうか。実はこちらで検索したら、CL値が調べられるとあったので、EVERESTなるソフトをダウンロードして解凍したら、解凍しただけでブルーバックになりました・・。やはりメモリに何か起こってるのかと心配です。

投稿日時 - 2007-07-02 21:28:14

あなたにオススメの質問