こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

SATAのHDDでOSが起動しない

2年ほど使ったPATA接続のHDDの6Y160POの調子が悪くなったため
新しく買ってきたSATA2のST3320620ASというHDDを購入しました。
そのHDD一基でXPのインストールを行ったのですが、インストール途中でフリーズしてしまい、リセットボタンでもう一度
やり直そうとしたのですが、
Press any key to boot from CD…でキーを押すと
反応はするのですが、何度やっても
フォーマットなどを行う青い画面に行く前の
黒い画面で動かなくなるようになりました。

そこで、もともと使っていて既にXPのインストールをしてある
6Y160POを接続して、HDD二基の状態で再び行ったところ
無事に青い画面に行き、ST3320620ASの方にXPをインストールすることができました。

このHDDを二基接続している状態であれば
起動時にST3320620ASと6Y160POでOSの選択画面がでますが、
ST3320620ASを選んでも起動することができます。
そのときHDDは両方二つのパーティションに区切っていて
Cドライブが6Y160PO (OS)
DドライブがST3320620AS (OS)
Eドライブが6Y160PO
FドライブがST3320620AS 
という状態になってます。

ですが、6Y160POのHDDの接続を外しST3320620AS一基の状態にして
起動しようとすると
Boot Failure reboot and select proper Boot Device...
などと表示され起動することができません。

マザーボード:865PE Neo2-P Platinum Edition

下の状態で起動可能で
Primary IDE Master : 6Y160PO (PATA)
Primary IDE Slave : HL-DT-ST DVDRAM (PATA)
Secondary IDE Master :ST3320620AS (SATA)

下の状態だと起動できません
Primary IDE Master : 無し
Primary IDE Slave : HL-DT-ST DVDRAM (PATA)
Secondary IDE Master :ST3320620AS (SATA)

BIOSをアップデートしたりいろいろ弄ってみたりしたのですが
自分では直すことができませんでした。
アドバイスがあればよろしくお願いします。

投稿日時 - 2007-06-08 21:38:54

QNo.3067900

困ってます

質問者が選んだベストアンサー

SATAHDDの物理的故障は疑いましたか?
チェックツールで確認してみるといいかも知れません。

あと、PrimarySlaveに光学ドライブってのも少し気になります。
ジャンパがCableSelectになってたりしませんか?たまにMasterSlaveの設定をしっかりしてやるだけで不具合が直ることがあります。

インストール中のフリーズですがメモリーのDualChannelの同期が原因でとまったのと、AHCIドライバがだめで止まったことがあります。
メモリはクロックを落として解決しました。ドライバは標準でもいくところをF6でGIGABYTEから落としたやつを入れて解決しました。

投稿日時 - 2007-06-08 22:12:08

お礼

光学ドライブのジャンパがSlaveになっていたため
Masterに変更しHDD一基でOSを再びインストールしたところ
起動するようになりました。
ジャンパの設定がどう影響してるのか
よくわかりませんが、無事直りました^^
アドバイスどうも本当にどうもありがとうございました。

投稿日時 - 2007-06-09 07:34:20

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(2)

あなたにオススメの質問