こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Twistedをインストールしたい

お世話になります。
Xen を使ってみたいと思い Linux に Twisted を
インストールするところでエラーが出てしまい、つまずいております。
Twisted のバージョンを変えてトライしてもインストールできません。
環境は以下の通りです。

----------------------------------------
Vine Linux 3.2
Python 2.3.4
----------------------------------------

Twisted-2.4.0 の中に入っている TwistedCore-2.4.0 を
インストールしようとして出たエラーは以下の通りです。
(下記のものは2回目以降の install 実行画面です)

----------------------------------------
# python setup.py install
running install
running build
running build_py
running build_ext
Checking if C extensions can be compiled, don't be alarmed if a few compile errors are printed.
gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -pipe -march=i386 -mcpu=i686 -D_GNU_SOURCE -fPIC -fPI
C -I/usr/include/python2.3 -c conftest.c -o conftest.o
running build_scripts
running install_lib
byte-compiling /usr/lib/python2.3/site-packages/twisted/test/stdio_test_halfclose.py to stdio_test_h
alfclose.pyc
File "/usr/lib/python2.3/site-packages/twisted/test/stdio_test_halfclose.py", line 20
???
^
SyntaxError: invalid syntax
running install_scripts
changing mode of /usr/bin/manhole to 755
changing mode of /usr/bin/mktap to 755
changing mode of /usr/bin/twistd to 755
changing mode of /usr/bin/tap2deb to 755
changing mode of /usr/bin/tap2rpm to 755
changing mode of /usr/bin/tapconvert to 755
changing mode of /usr/bin/tkmktap to 755
changing mode of /usr/bin/trial to 755
running install_data
----------------------------------------


身勝手で大変申し訳ありませんが、
勉強のために Vine Linux で Xen をインストールすることを目指しておりますので
ディストリビューションを変更するという回答以外でお願いいたします。

それではよろしくお願いいたします。

投稿日時 - 2007-04-26 00:58:31

QNo.2951056

困ってます

質問者が選んだベストアンサー

> Checking if C extensions can be compiled, don't be alarmed if a few
> compile errors are printed.
> gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -pipe -march=i386
> -mcpu=i686 -D_GNU_SOURCE -fPIC -fPI
> C -I/usr/include/python2.3 -c conftest.c -o conftest.o

や、これはエラーメッセージではないですよ。
Pythonの流儀はまだよく知らないのですが、多分 conftest.c というファイルは
使用するライブラリとはヘッダがシステムにあるかどうかを確認するために
一時的に作られるファイルです。
システムの状態によってはこのファイルのコンパイル時にエラーが出ることもありえます。
ですから、メッセージのとおり

「Cによる拡張が最終的にビルドできているのなら
コンパイルエラーが途中で出ても気にしないでね」

ということだと思うんですが。
最終的に作成されるであろう .so とか .la の拡張子を持ったファイルが
できていないのなら、もっと直接的なエラーメッセージが出ているはずなので、
その辺確認してみてください。

投稿日時 - 2007-04-27 03:08:58

お礼

そうだったんですか!
早速、ファイル検索をかけて調べてみると
きちんとインストールされていました。
早とちり、お恥ずかしい限りです…。
きちんと英語と Linux の勉強をしていこうと思います。

これでようやく前に進むことが出来ました。
本当にありがとうございました!

投稿日時 - 2007-04-28 00:52:59

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.2

複数のバージョンを試されたとのことですが、
少なくとも 2.4.0に関しては以下のような事情のようです。

#1740 (twisted/test/stdio_test_halfclose.py typo) – Twisted – Trac
http://twistedmatrix.com/trac/ticket/1740



So, I had brought this up on IRC awhile back, but it appears that

source:/trunk/twisted/test/stdio_test_halfclose.py@current#L20

has the string "???" inserted as a placeholder.

This is especially an issue for Debian, as every time you install a Python-related package it recompiles the site-packages directory, and if that fails, it tends to stop the package install/config process.

ということで該当の行(エラーメッセージに出てますよね)
を見れば対応策はわかると思いますよ。

投稿日時 - 2007-04-26 11:26:53

補足

アドバイスありがとうございます。
語弊がありまして申し訳あません。
複数のバージョンをインストールではなく、同じバージョンのものを
もう一度 install した結果が質問内容にあるエラーメッセージとなっております。

該当のテキストは見たのですが…、さっぱり分からず、
いろいろなサイトを巡って調べたのですが
どうやら Twisted と ZopeInterface の互換性? がシビアらしく、
結局 ZopeInterface-3.0.1 をインストールしてから
Twisted_NoDocs-1.3.0 のインストールを行いました。
「???」が出るエラーはなくなったのですが、それでもやはり

Checking if C extensions can be compiled, don't be alarmed if a few compile errors are printed.
gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 -pipe -march=i386 -mcpu=i686 -D_GNU_SOURCE -fPIC -fPI
C -I/usr/include/python2.3 -c conftest.c -o conftest.o

のエラーがでてしまいます。
gcc がらみのエラーかと思い、該当しそうな gcc をインストールしたのですが、やはり結果は変わりませんでした。
なお、インストールしている gcc は
  gcc, gcc-c++, libgcc, gcc-cpp, gcc-java, gcc-objc, gcc-docs
です。

投稿日時 - 2007-04-26 23:15:23

ANo.1

出力されているエラーメッセージにしたがって調べてください。
では、勉強がんばってください。

投稿日時 - 2007-04-26 06:01:38

お礼

ありがとうございます。
もっといろんなことを視野に入れて勉強を頑張りたいと思います。

投稿日時 - 2007-04-26 22:49:15