こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

tomcatとservletの関係

表は要するにどうゆう意味かわかりません。最新のservlet2.5はjdkの何をつかえばいいのか?

Servlet/JSP Spec Apache Tomcat version
2.5/2.1 6.0.x
2.4/2.0 5.5.x
2.3/1.2 4.1.x
2.2/1.1 3.3.x

投稿日時 - 2007-03-17 18:20:54

QNo.2841526

困ってます

質問者が選んだベストアンサー

左のServlet/JSP Spec のところは,Servlet,JSPという仕様(規格)のそれぞれのバージョンです.
その仕様を満たすように実装されたTomcatはどのバージョンなのかを表すのが,右側のApache Tomcat version です.

> 最新のservlet2.5はjdkの何をつかえばいいのか?

JDKのバージョンは直接は関係ありません.
Servletの2.5を使いたいのなら,表の通り,Tomcat 6.0.xが必要です.
JDKのバージョンは,そのTomcat 6.0.xがどのJDKを必要とするかで決まります.そして,Tomcat 6.0は,J2SE5以降を必要とするようですので,必要なJDKは5.0以降ということになります.

投稿日時 - 2007-03-17 21:10:08

補足

jdk5なので使えそうだ。

投稿日時 - 2007-04-06 00:08:43

ANo.1

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(1)