こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

アパッチなどのバージョンについて

Linux などの OS を使ってサーバーを作ろうと考えていますが、その前に、Eclipse(Windows) で書いたプログラム(Java)のしくみ(ファイルの配置など)をある程度把握しておきたいので、IDE を使わずにWindowsで Apache-Tomcat-J2SDK-MySQL を連携させようと思います。参考書やホームページを見比べながらやっているのですが、バージョンがばらばらで困っています。どなたか、教えていただけないでしょうか。
 ・新しいバージョンは古いバージョンをカバーしていると考えていいので  しょうか?
 ・ほぼ同じ時期に二つのバージョンが出ていますが
  (例えば、Apache 2.0.58 と 2.0.59)はどちらを使えばいいのか
  わかりません。(英語を読めるようにしないといけないと思います)
お手数をおかけして、申し訳ございませんが、ご助言をお願い致します。

投稿日時 - 2007-01-09 12:27:46

QNo.2653697

困ってます

質問者が選んだベストアンサー

・Apache
 1.3系と2.0系でセットアップが異なります。
 2.2系は良く見てないので分かりません。
・Tomcat
 気にした事なかったので分かりません。
・SDK
 作成したプログラムが動作するバージョンにしましょう。
・MySQL
 3.23系、4.0系、4.1系、5.0系でセットアップが異なります。

基本的に、新しいバージョンは古いバージョンをカバーしています。
質問にあるようなApache等のバージョン違いはバグフィックスと考えて良いです。

投稿日時 - 2007-01-09 12:45:57

お礼

早々にご回答下さいまして、誠にありがとうございます。
これで先に進めることができます。
ありがとうございます。

投稿日時 - 2007-01-10 09:05:32

ANo.1

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.3

>(例えば、Apache 2.0.58 と 2.0.59)はどちらを使えばいいのか
>  わかりません。(英語を読めるようにしないといけないと思います)
2.0.58=>2.0.59については
http://www.apache.org/dist/httpd/ にあるCHANGES_2.0.59 に書いてあります
英語ですが 翻訳サイトと検索エンジンである程度は内容が判りますよ
例えば http://www.google.co.jp/language_tools?hl=ja にアクセスしてCHANGES_2.0.59 の内容を貼り付けて[翻訳]ボタンを押します
で「CVE-2006-3747」なる言葉が出てくるので その単語で検索すると
mod_rewriteモジュールの脆弱性への対策であることが判ります

投稿日時 - 2007-01-09 22:19:52

お礼

早々のご回答、ありがとうございます。
これから進めてゆくうえで、英語とは向き合わなければいけない
気がしますので、お教えいただいたやり方はとても参考になりました。
助かりました。ありがとうございます。

投稿日時 - 2007-01-10 09:13:38

ANo.2

No1補足

・Apache
2.0と2.2は設定が大幅に違う。インストール(make含)自体は同じ
設定が大きく違うせいで移行するためにはhttpd.confを大幅に書き換えなければならないので前verが有るならバックアップして2.2.xを新規で入れてから2.0.xのhttpd.confを見ながら修正する方が早いかも
・tomcat
4.xと5.xで要求するjavaのverが違う。
構成ハードウェアのせいでjavaのverを上げる事ができない場合はtomcatのverを低くせざるを得ない。
・J2SDK
構成ハードウェアによってはglibcというライブラリのverを要求する場合有り。glibcはkernelのverによってやはり同じように………。


x86系ならそんな心配する必要は無いんだけど一応自分がハマった事を書いといた

投稿日時 - 2007-01-09 13:09:19

お礼

早々のご回答、ありがとうございました。
系列の最新版をインストールして、先に進みます。
(バージョンを気にするレベルに、まだ自分は達していない
ので、あまり気にしないことにします)

投稿日時 - 2007-01-10 09:09:11

あなたにオススメの質問