こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Firefox を1.5 にアップしたら変です。

OS:WinXP-HE

Firefox を 1.5 にアップグレードしたら検索機能はヤフーのみが表示されます。
いままで右上にあった検索の選択機能は空になっています。
一度アインストールして再度インストールしても変化ありません。
それどころかアンインストールする前にプライバシーの設定を変更しましたが、再インストール後も設定がそのままになって初期化されてません。

そこでもう一度アンインストール後にフォルダごと捨てて Program Files 内にある Mozxilla Firefox フォルダを完全に削除し、再起動後に再度インストールしました。
それでも全然変化ありません。
プライバシー設定もそのまま、Cookie>例外サイト内のログも消えずに残ったままです。
どなたかご教授ください、もう完全にお手上げです。
よろしくお願いいたします。

投稿日時 - 2006-08-12 00:23:44

QNo.2334558

困ってます

質問者が選んだベストアンサー

そういった設定は「Program Files」ではなく「Documents and Settings」に保存されると思います。

ですのでアンインストールしたあとに「Documents and Settings」→「ログオン名フォルダ」→「Application Date」→「Mozilla」が残ってしまっているのかもしれません。

残っていたとしたら削除したほうがいいかもしれませんね。

ちなみに「Application Date」から以降のフォルダは隠しフォルダです。

コントロールパネルにある「フォルダオプション」の設定で「すべてのファイルとフォルダを表示する」にしないと表示されませんので。。。

もちろん隠しファイルですので大切なファイルです。
誤った操作をしてはいけないため隠しフォルダになっておりますので十分注意をしてください。

アンインストール後に、そのファイルが削除されているかどうか確認する程度なら大丈夫ですが。

あくまでも参考にしてみてください。
実行の際は自己責任でお願いします。

投稿日時 - 2006-08-12 01:11:17

お礼

ありがとうございます。おかげさまで解決しました。
検索プラグインの窓の中が空になってましたが、それもキッチリ入っています。

投稿日時 - 2006-08-12 23:00:12

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(3)

<Firefox を1.5 にアップグレード>
これは以前にFirefox1.0系でも使用されていたということですか?
もし、1.0系を使用されていて、今回1.5系にされたということなら、1.0系のプロファイルデータが残っていて、それが関連づけられたままで1.5系がうまく機能しないことが考えられます。

検索機能はdefaultでプログラムに組み込まれていて、何もしなくてもYahooはじめ何個かの検索プラグインが組み込まれています。
Safemodeで1.5(.0.6)を起動(プログラム一覧のアイコンから起動できます)してみて、状況が変わらないなら、以前のバージョンの影響が出ているのではないかと思います。

Mozilla SuitsやFirefoxの以前のバージョンをアップデートする場合は、一旦、旧バージョンをアンインストールしてから新しいバージョンをインストールしていましたが、1.5系から更新データのみによるアップデータ方式になっていると思います。
従って、仮に1.0系をアンインストールされてから1.5系をインストールしたとしても、系列が異なるブラウザなので、同時にプロファイルを削除なりしておかないと不具合が発生するかも知れません。

現在インストールされている1.5(.0.6)をアンインストールした上で、
C\Documents&Settings\user名\ApplicationData(隠しフォルダ)にあるMozillaという名前のフォルダを手動削除し、もう一度インストールしてみてください。
なお、アンインストール後にProgram filesにMozilla Firefoxのフォルダがあれば、それも手動で削除しておいた方が良いでしょう。
http://firefox.geckodev.org/index.php?%E3%83%97%E3%83%AD%E3%83%95%E3%82%A1%E3%82%A4%E3%83%AB
http://firefox.geckodev.org/index.php?%E6%A4%9C%E7%B4%A2%E3%82%A8%E3%83%B3%E3%82%B8%E3%83%B3%E3%81%AE%E8%BF%BD%E5%8A%A0#ufd98c32

投稿日時 - 2006-08-12 17:06:22

お礼

ありがとうございます。
せっかく詳細な説明をいただきましたが、アドバイスを順番に試したところ No.2 の方の方法で解決しました。
詳細な説明にお手間をとらせて申し訳ありませんでした。

投稿日時 - 2006-08-12 23:03:42

ANo.1

インストール時に特別設定をいじっていなければ
"C:\Documents and Settings\(ユーザー名)\Local Settings\Application Data\Mozilla\Firefox\Profiles"
に設定情報が保存されているので、これを削除して再インストールしてみては。

投稿日時 - 2006-08-12 00:58:25

お礼

早速のアドバイスをありがとうございます。
残念ながらアドバイスどおりに削除しましたが変化ありませんでした。
"Mozilla\Firefox\Profiles" ではなく、
No.2の方が言われたとおり "Mozilla" フォルダをソックリ削除したら解決しました。

投稿日時 - 2006-08-12 22:58:21

あなたにオススメの質問