こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Windows 98SE のパソコンをもらったのですが

友人からGateway のデスクトップパソコン(Windows 98SE,
をもらいました。
ハードディスクが消去されているようなのですが、
OSをインストールすることができません。
教えていただければ幸いです。

電源を入れてからの画面は以下のようになります。

電源のスイッチを入れると、
まず、'Gateway'のロゴの画面が数十秒表示されます。

その次の画面で、
'Invalid Boot Diskette
Insert BOOT diskette in A:_'
と表示されますので、
付属のWin98SE 起動ディスクのFDを挿入し、
'Enter'を押します。

その後、
'Microsoft Windows 98 Startup Menu
----------------------------------
1. Start Windows 98 Setup from CD-ROM.
2. Start computer with CD-ROM support.
3. Start computer without CD-ROM support.
Enter a choice: 1 Time remaining:

と出ますので、Windows 98SE の CD-ROMを入れますと、
次のように表示されます。

(…途中省略…)
Device Name : OEMCD001
No drives found, aborting installation

(…途中省略…)

PCI bus scan complete.

(…途中省略…)

それから、キーボードのタイプを判定の次の画面で、

「デバイスドライバが見つかりません: 'OEMCD001'
 有効な CDROM デバイスドライバが選択されていません。
 Windows 98 セットアップ ファイルが見つかりませんでした。
 A:\>_    」
となってしまいます。

どうすればよいのでしょうか?
よろしくお願いいたします。

投稿日時 - 2006-06-10 20:04:20

QNo.2207512

困ってます

質問者が選んだベストアンサー

ANO.6です。
通常フォーマットされていないHDDでも、きちんとIDEのケーブルと電源ケーブルをつなげばHDDの型番は表示されるはず。
それなのに表示されないとはなぜ?
HDDとマザーボード両方がきちんとつながっていて電源を入れた時にHDDが回転する音は聞こえますよね?
CDDの方は他の回答者の方が色々アドバイスされているので任せます。
一度頂いた方にHDDの型番が表示されていたか確認してみたらいかがでしょう?
こちらが認識されないとインストール先が無いのでエラーになっているかもしれません。

投稿日時 - 2006-06-11 22:30:13

補足

ありがとうございます。
HDDが回転する音を確認するために、箱を開けて、電源を入れてみました。
すると、どうもHDDがあるあたりからは音が聞こえてきません。
ファンの音がうるさいので、ファンのケーブルを抜いてやってみましたが、やはりそうです。
電源のコネクタのあたりからしか音がしてないようです。
そこで試しにHDDを取り外して電源を入れてみたところ、当初の(「質問」に私が書いたの)とまったく同じ表示になりました。
もう一度HDDを取りつけて(IDEのケーブルと電源ケーブルをつないで)、電源を入れてみましたが、やはり同じです。接触不良が直るかと思いましたがダメでした。
これは、
1.HDDの電源ケーブルに接触不良など何らかの問題がある。
2.IDEのケーブルに接触不良など何らかの問題がある。
3.HDDそのものに問題がある(交換する必要がある)。
4.その他
といった理由があるのではと推測しますが、どうでしょうか?
よろしくお願いいたします。

投稿日時 - 2006-06-15 15:50:20

お礼

No.9への補足で「アダプタを買ってきて、2.5インチHDDを接続してみましたが、ダメでした」と書きましたが、実は逆差しをしていたことが分かりました(よく壊れなかったと思いましたが…)。本来の向きに差したら、OKでした!無事ウィンドウズもインストールできまして、動いてます。
結局HDがダメだったということですね。
アドバイスありがとうございました!助かりました。

投稿日時 - 2006-06-23 05:04:45

ANo.7

このQ&Aは役に立ちましたか?

2人が「このQ&Aが役に立った」と投票しています

回答(10)

ANo.10

同じ症状で悩んでいて、検索したところこのページが引っかかりました。ここの回答を見ても残念ながらわかりませんでしたが、自己解決したので、自分の解決法をお知らせします。

DELキーを押しながら起動して、BIOSを立ち上げます。
「Main」の「IDE Configuration」を選択。
「Onboard IDE Operate Mode」を「Compatible Mode」にする。
変更をセーブして再起動。

以上で、ウィンドウズ98やMeでもCD-ROMを認識すると思います。
ちなみに、2000やXPをインストールする時には、「Enhanced Mode」にする必要があります。

AMIのBIOSでの設定ですが、他社のBIOSでも、同じような項目を探していろいろ試せば、うまくいくでしょう。

投稿日時 - 2006-06-22 13:57:07

お礼

ご回答ありがとうございます。
先ほど回答7の「お礼」に書きましたが、
結局HDが壊れていたようで、交換したら直りました。

投稿日時 - 2006-06-23 05:07:18

ANo.9

1.HDDの電源ケーブルに接触不良など何らかの問題がある。
2.IDEのケーブルに接触不良など何らかの問題がある。
3.HDDそのものに問題がある(交換する必要がある)。
4.その他

これの切り分けに関しては、 Secondary IDE Slave [CD-224E ]と認識されているようなのでCDDの部分のIDEケーブルと電源ケーブルとHDDのケーブル類を差し替えればわかります。
差し替えた後にSecondaryにHDDが認識されればケーブル不良(もしくは、M/Bのコネクタの不良)。
認識されなければHDDの不良。(これは、もう新しいHDDを購入してください。)
もし、Primaryのコネクタ等に問題があるならSecondaryのMasterにHDD SlaveにCDDをつないでセットアップしてみてください。
もう少しです。切り分けを頑張って下さい。

投稿日時 - 2006-06-15 20:23:07

補足

アダプタを買ってきて、2.5インチHDDを接続してみましたが、同じでした。
電源のケーブルは、HDDへつなぐコネクタを経由してFDDへつながっているので、おそらく問題ないと思うのですが(あるとすればコネクタ部分の不良ですね)。
まずは、IDEケーブルを買ってきて交換してみたいと思います。
でも、IDEケーブルって見たところかなり頑丈そうなので、これで果たして直るのでしょうか?

投稿日時 - 2006-06-17 19:05:48

お礼

ありがとうございます。
でも、ケーブルの差し替えをしようとしたら、
CDDのIDEケーブルと、HDDのIDEケーブルとでは、コネクタの部分の形状が異なっていて(CDDのほうが若干薄い)、差し替えができませんでした。
以前ノートパソコンで使っていた2.5インチHDDがあるので、アダプタを買ってきて接続してみたいと思います。

投稿日時 - 2006-06-15 22:46:41

ANo.8

#3等です。

> Primary IDE Master [Not Installed]

私も見忘れてました。汗

念のため、最初のメニューで「3」を選択してから、fdisk をしてみるとどうなるでしょうか?

投稿日時 - 2006-06-14 20:00:32

補足

ありがとうございます。
「3」を選択してから、fdisk をしてみましたが、
やはり(No.7の補足)「ハードディスクはありません」と表示されました…。
ハードディスク、電源ケーブル、IDEケーブル、どれを交換したら直るでしょうか?

投稿日時 - 2006-06-15 16:00:51

お礼

先ほど回答7の「お礼」に書きましたが、
結局HDが壊れていたようで、交換したら直りました。
いろいろとアドバイスありがとうございました。

投稿日時 - 2006-06-23 05:08:21

ANo.6

#NO.3の方の回答に対する補足にある
> Primary IDE Master [Not Installed]
> Primary IDE Slave [Not Installed]
> Secondary IDE Master [Not Installed]
> Secondary IDE Slave [CD-224E ]
これを見るとHDD自体が無いように思われますが、
中にはちゃんと入っていますよね?
チョット気になったもので質問させていただきました。

投稿日時 - 2006-06-11 11:01:47

補足

はい。
HDDはカバーを開けて確認しましたが、
中にちゃんと入っていますし、
接続もきちんとされていると思うのですが…。

なぜ[Not Installed]になってしまうのでしょうか?

投稿日時 - 2006-06-11 19:13:29

ANo.5

>This driver is provided by Oak Technology.
>OTI-91X ATAPI CD-ROM device driver, Rev D91XV352
>(C)Copyright Oak Technology Inc, 1987-1997
>Device Name : OEMCD001
>No drives found, aborting installation
うーん、BIOSで認識していて、DOSで認識していない・・
普通はこの時点で認識できるはずなんです。汗

>これをCDイメージとして焼くにはどうしたらいいのでしょうか?

これは別途質問したほうがいいと思います。
お使いのCD-Rライターによりますので・・・
#XP標準では焼けません・・・

あ、一応、説明忘れましたが、これは、メモリチェックプログラムで、他になにかあったときに有用かと思います。

ちなみに、これが起動できれば、とりあえずDOS部分の問題になります。

投稿日時 - 2006-06-11 08:11:15

ANo.4

BIOS上だと正常のようですね。

念のため・・・
(…途中省略…)
Device Name : OEMCD001
No drives found, aborting installation

(…途中省略…)

PCI bus scan complete.

以上の途中省略の部分と、
config.sys の /D: が存在する行と
autoexec.bat の mscdex が存在する行を
提示してもらえますか?

その他、本体を開けられるなら、CD-ROMのドライブのコネクタが正常に起動できますか?

また、これは確認できるかどうか不明ですが、以下のCDを入れてみて自動起動するか確認できるでしょうか?
・Windows Me CD-ROM
・Windows 2000 / XP
・メーカー製リカバリ(CDから起動するタイプのみ)
・上記のどれもなければ、以下のものをCDイメージとして焼いたもの・・ファイルで焼かないように!! (XPの標準ライターはファイルでしか焼けません)
 http://www.memtest86.com/ v3.2 ISO Image

(最初の一瞬が起動できればOKなので、その後リセットしていただいて構いません)

投稿日時 - 2006-06-10 23:59:49

補足

ありがとうございます。
途中省略の部分(書いた部分も含めて)は以下の通りです。


This driver is provided by Oak Technology.
OTI-91X ATAPI CD-ROM device driver, Rev D91XV352
(C)Copyright Oak Technology Inc, 1987-1997
Device Name : OEMCD001
No drives found, aborting installation

AIC-6260/6360/6370 ASPI Manager for DOS
Version 3.68S
Copyright 1990-1997 Adaptec, Inc.

AIC-78XX/AIC-75XX ASPI Manager for DOS
Version 1.32S
Copyright 1994-1997 Adaptec, Inc.

PCI bus scan complete.

AHA-1540/1542/1640 ASPI Manager for DOS
Version 3.36S
Copyright 1989-1997 Adaptec, Inc.

AIC-7890/91 ASPI Manager for DOS
Version 1.00S
Copyright 1994-1997 Adaptec, Inc.

PCI bus scan complete.

ASPI CD-ROM Driver for DOS
Version 4.01S
Copyright 1990-1996 Adaptec, Inc.

また、
本体を開けられますが、
「CD-ROMのドライブのコネクタを正常に起動する」
のはどうやって確認するのでしょうか?

http://www.memtest86.com/
から、
Download - Memtest86 v3.2 ISO image (zip)
をダウンロードして、開いたところ、
memtest86-3.2.iso
というファイルができました。
これをCDイメージとして焼くにはどうしたらいいのでしょうか?
わからないことだらけですみませんが、
よろしくお願いいたします。

投稿日時 - 2006-06-11 07:23:01

お礼

遅くなって申し訳ございませんが、補足する時に
よく分からなかったので、飛ばした部分があります。
未だによく分からないので教えていただければ幸いです。
「config.sys の /D: が存在する行と
autoexec.bat の mscdex が存在する行」
はどうやって出したらよいのでしょうか?
また、
http://www.memtest86.com/ v3.2 ISO Image
をCDイメージとして焼いたCDはいつ入れたらよいのでしょうか?
また「自動起動」とはこの場合、どういうことでしょうか?そして「最初の一瞬が起動」とは?
ちなみに、このCDと起動ディスクを入れた状態で電源を入れてみましたが、前と同じでした。
あと、「メーカー製リカバリ」というのは「Gateway System CD」とは別のものでしょうか?
なんだか質問ぜめになってしまってすみません。
よろしくお願いします。

投稿日時 - 2006-06-15 16:36:04

ANo.3

>Device Name : OEMCD001
>No drives found, aborting installation

>「デバイスドライバが見つかりません: 'OEMCD001'
> 有効な CDROM デバイスドライバが選択されていません。
> Windows 98 セットアップ ファイルが見つかりませんでした。

CD-ROMドライブが認識していないようです。
BIOSでCD-ROMが殺されていないか確認してみてください。

投稿日時 - 2006-06-10 21:11:33

補足

ご回答ありがとうございます。
BIOSで'IDE Configuration'の画面を出したところ、

IDE Controller [Both]
Hard Disk Pre-Delay [6 Seconds]
Boot Sector Anti-Virus [Disabled]

> Primary IDE Master [Not Installed]
> Primary IDE Slave [Not Installed]
> Secondary IDE Master [Not Installed]
> Secondary IDE Slave [CD-224E ]

となっていますが、これはどういうことなのでしょうか?

投稿日時 - 2006-06-10 22:51:14

ANo.2

インストールCD-ROMを入れた状態で
起動ディスク1に入れ替え(製品に付属の「付属のWin98SE 起動ディスク」をお使いの場合はディスクは1枚ですので、入れ替え作業は不要です)、
A:\>d:\setup
と入力します。「d:」の部分は起動ディスクで立ち上げる途中で認識されたCD-ROMドライブのドライブレターを記述してください。
そのパソコンにSCSIコントローラカードやIDEコントローラカードが搭載されている場合は、
A:\>d:\setup /is/im/ie
と入力して、余計な作業を要求しないようにしないと、インストール作業が途中で止まります。

投稿日時 - 2006-06-10 20:47:42

補足

ご回答ありがとうございます。
No.3の方のご指摘どおり、CD-ROMがダメなようで、
A:\>d:\setup
の「d:」の部分に、c~fまでいろいろ入れて
やってみましたが、
すべて「無効なドライブの指定です」と出ました。

投稿日時 - 2006-06-10 23:15:51

ANo.1

最初の画面で、1. Start Windows 98 Setup from CD-ROMを選択していますか?
自作パソコンの98SEしかインストールしたことがありません^^;。以下参照に。
起動FDは2枚必要です。まずFD1を入れてしばらく待ち、指示があったらFD2に入れ替えてから何かキーを押す。FDが止まったら再びFD1に入れ替えて setup c:を。自作パソコンの場合は予め、fdisk やformat を終了させておきます。^^;少しは参考になりますでしょうか。

投稿日時 - 2006-06-10 20:24:39

お礼

ご回答ありがとうございます。
1. Start Windows 98 Setup from CD-ROMを選択しました。また、Hogeoyadiさんの言われるように、
付属の起動ディスクは1枚だけでした。

投稿日時 - 2006-06-10 22:50:35

あなたにオススメの質問