こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

1台のパソコンでWindowsと共存している時のLinuxのネットワーク設定

よろしくお願いします。
WindowsXPインストールパソコン(hpのノートパソコンcompaq nx9030)に、FedoraCore4をデュアルブートでインストールしました。Cドライブをソースネクストのパーティション分割ソフトで分割することで、ここまではうまくいきました。
しかしLinuxの方のネットワーク接続がうまくいきません。
わたしの所のネット環境は、いわゆるインターネット対応マンションで、マンション全体でプロバイダーのOCNと契約しており、各戸にIPアドレス、サブネットマスク、デフォルトゲートウェイ、DNSサーバの設定値が指定されています。
WindowsとLinuxを共存させた後でも、windowsはインターネットを使えるのですが、FedoraCore4の方は同じ設定値を入れても、URLを指定して実行すると、
警告「・・・が見つかりません。ドメイン名を再確認してください。」と出て、ネット接続ができません。
この場合のネットワーク設定のやり方を知っている方がいらっしゃれば、教えてください。

投稿日時 - 2006-04-24 01:32:40

QNo.2110603

困ってます

質問者が選んだベストアンサー

まず、どこに問題があるのか切り分ける必要があります。
ping goo.ne.jp
では、なんと応答しますか?
ping 210.150.25.37
ではどうでしょう?

前者がping: unknown host goo.ne.jp
で後者は応答するなら/etc/resolv.confの問題。
両者ともエラーなら、ネットワークにアクセスできていないわけです。

ネットワークにアクセスできていない場合、
/sbin/ifconfig
を実行して結果を報告してください。

/etc/resolv.confの設定法は、自分で調べられると思います。

投稿日時 - 2006-04-24 19:43:47

お礼

ご指導ありがとうございます。
前者がping: unknown host goo.ne.jp
後者もconnect: Network is unreachableで
ネットワークにアクセスできていませんでした。

/sbin/ifconfigを実行しますと

eth0 Link encap:Ethernet HWaddr 00:C0:9F:6E:E1:DC
inet addr:10.12.207.41 Bcast:8.10.255.255 Mask:255.255.0.0
inet6 addr: fe80::2c0:9fff:fe6e:e1dc/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:2482 (2.4 KiB)
Interrupt:10 Base address:0x3000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 Mask:255.255.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:24 errors:0 dropped:0 overruns:0 frame:0
TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1712 (1.6 Kib) TX bytes:1712 (1.6 KiB)

となりました。

投稿日時 - 2006-04-25 00:12:24

ANo.3

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

eth0は生きていますが設定がでたらめのようですね。
install中のネットワーク設定がよくなかったのでしょうか?
手元にあるのがdebianなので設定ファイルの位置が異なります。
LANのアドレスは192.168.0.0/24でしょうか?
ここからは記憶に頼っているのであやふやです。
/etc/sysconfig/network-scripts/ifcfg-eth0を修正します。
DEVICE=eth0
BOOTPROTO=static
BROADCAST=192.168.0.255
IPADDR=192.168.0.2
NETMASK=255.255.255.0
ONBOOT=yes
TYPE=Ethernet

LANに合わせてDHCPで割り当てていない固定アドレスを振ってみてください。
/etc/sysconfig/network
HOSTNAME=xxxx
GATEWAY=192.168.0.1
ルーターのアドレスを指定します。

/etc/resolv.conf
nameserver プロバイダ指定のdns ip addr

再起動してもう一度さっきやったのと同じチェックをしてみてください。
でも、先に申し上げたとおりFedoraCore4は手元に無いので、これ以上アドバイスは無理です。

どなたかよろしく (^^;

投稿日時 - 2006-04-25 01:10:41

お礼

すみません。お陰さまでつながりました。
設定を変更した後、すぐ再起動をしなかったため、
設定が変更になっていなかったようです。
お騒がせしました。

投稿日時 - 2006-04-26 02:16:52

ANo.2

>pingの確認なども今ひとつ意味がわからずやっておりません。
Linuxうんぬんの問題以前です。
Windowsでも使います。

そもそもネットワークのドライバはロードされて
正常に動いているの?

投稿日時 - 2006-04-24 10:18:37

ANo.1

私のところでは同じ値を指定すればOKですが...
ifconfigでネットワークの設定は終わっているでしょうか?
プロキシサーバなどの指定も同じでしょうか?
127.0.0.1へのpingは成功しますか?
ネットワークのデーモンは起動していますか?

投稿日時 - 2006-04-24 01:39:38

お礼

ご回答ありがとうございます。
実は、UNIXの勉強をしようと思い、LINUXのインストールをしたのが真相なので、pingの確認なども今ひとつ意味がわからずやっておりません。
ご指摘のものを本で調べるなどして、やってみようと思います。

投稿日時 - 2006-04-24 07:47:36

あなたにオススメの質問