こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

HP読み込み時のエラー表示について

自分で作ったHPをWinのIEで開くと「実行しましたがページでエラーが発生しました」のメッセージがでます。(Netscap/Firefox、MacのIEやNetscapでは大丈夫でした)。HPは 1.Infoseekの無料サーバー(広告付)を使用 2.Infoseekのアクセス解析設置 3.一部自作のFlashが有 4.Getflashのバナーを設置 5.アフェリエイト機能付バナー設置 という感じです。メッセージは出ますが、見た目やリンク等問題は見つかりません。このようなエラーはどういったことが原因で出るものなのでしょうか。htmlの記述の仕方が悪いと出るものですか?それとも勝手に加わったジャバスクリプトなどが原因なのでしょうか?どこを見直せばいいのかアドバイスをいただけないでしょうか。

投稿日時 - 2005-10-10 17:55:29

QNo.1704731

すぐに回答ほしいです

質問者が選んだベストアンサー

IEのツール~インターネットオプションの詳細設定で
□スクリプトのデバッグを使用しない
にチェックが付いていたらチェックをはずします。
するとエラーが発生するとデバッグするかどうか聞いてくるので、
[はい]を選ぶとスクリプトのデバッグ画面になります。
中断を選ぶとエラーを起こしている行が→で表示されます。

投稿日時 - 2005-10-10 19:50:31

補足

早速の書き込みありがとうございます。「スクリプトデバッグを使用しない」のチェックをはずしただけでは何も変わりませんでした。よく分からないのですが「スクリプトエラーごとに通知を表示する」のチェックをオンしてみたところ「ライン:2、文字:1、エラー:構文エラーです、コード:0」と出ました。これがおっしゃっているエラー表示でしょうか?もし、そうだとしたらこの意味と対策を教えていただけると嬉しいのですが。

投稿日時 - 2005-10-10 23:12:57

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

問題がありそうなところを外してみたらどうですか?
問題の部分を絞ることが出来ると思います。

(広告の位置を変えたりすると不正行為みなされる場合があるで、そこらへんは注意してやってください)

http://www.microsoft.com/Japan/msdn/Scripting/Debugger/docs/sdbug_8.htm
構文エラーについてかかれています。

投稿日時 - 2005-10-11 20:02:50

お礼

書き込みありがとうございます。やっと解決しました。自動で入ってくる広告部分の一部が別の部分(Javascript)に少し食い込んだ形(半入れ子状態とでも言えばいいのでしょうか)になっていたのを直し、さらにJavascript場所を変更してみたら直りました。お手数おかけしました。構文エラーについてのサイトも今後に役立てたいと思います。ありがとうございました。

投稿日時 - 2005-10-11 21:25:31

ANo.3

>ライン:2、文字:1、エラー:構文エラーです、コード:0
は、スクリプトの2行目の始めで文法エラーがあるというエラーでそれだけではどういうエラーかはそれ以上はわかりません。
あと、行数はずれる場合があります。

>スクリプトエラーごとに通知を表示する」のチェックをオン
は、いちいちエラー毎でるので、鬱陶しいので、オンにしなくてもいいかと
思います。
#2の設定で、エラーがでたときに
「デバッグしますか」というメッセージがでるはずなんですが・
よければ、そのHPのアドレスを補足していただけますか。
(OKWebではHPのアドレスをアップするとそのアドレス部分は編集されるか削除されてしまいますので、スクリプト部分をアップしてもらう方がいいですが、状況が変わってしまう場合があります。)

投稿日時 - 2005-10-11 01:29:46

お礼

何度もありがとうございます。やっと解決しました。自動で入ってくる広告部分の一部が別の部分(Javascript)に少し食い込んだ形(半入れ子状態とでも言えばいいのでしょうか)になっていたのを直し、さらにJavascriptの場所を変更してみたら直りました。なぜ急にエラーが出るようになったのかは分かりませんが、おかげで解決しました。ありがとうございました。

投稿日時 - 2005-10-11 21:23:09

ANo.1

こんにちは。

Javascriptの記述にミスがあると、そのエラーが出ます。
2.~5.の各コンテンツのどれが原因かわからないので
1つずつ載せて、検証してみてはどうでしょうか。

投稿日時 - 2005-10-10 18:44:27

補足

お返事ありがとうございます。まず1の無料広告と2のアクセス解析を設置していたときは、エラーは出ていなかったと記憶しています。そして3~5をすべてはずしてみたのですが、やっぱり同じエラーが出ます(BLUEPIXYさんの「デバックのチェックボックスをはずしてエラー内容をみる」をやってみたときと同じエラー内容でした)。さらに(infoseekの無料サーバーを2つ借りているので)、まったく同じページ(1-5全て設置)をもうひとつのアドレスの方に移動させたところ、こちらではエラーは出ませんでした。これをどう考えていいのか分かりません。。。

投稿日時 - 2005-10-11 00:42:52

あなたにオススメの質問