こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

DBDが動作しません。

現在AIXにpostgreSQL(ver.7.2.1)を導入したいと考えております。
また、perlを使用し、DBI(ver.1.42)、DBD(ver.1.31_7)モジュールを使用します。
すべてのモジュールの導入は済み、検証しようとしていたところ、DBDがうまく動作していないというエラーが表示されておりました。
そこで、DBDのバージョンが違うのではないか?ということで、DBDが正常に動作できるように別バージョンを
インストールしています。しかし下記のようなエラーが表示されて先に進めずに困っております。
どなたかわかる方アドバイスをお願い致します。

◆環境
AIX5.1
postgreSQL 7.2.1
perl 5.6.0
DBI 1.42
DBD1.2
DBD1.2を導入しようとしているのですが、perl Makefile.PL
を実行した時点で以下のWarningが表示されます。
------------------------------------------------------------------------------
Warning: prerequisite Test::Simple failed to load: Can't locate Test/Simple.pm in @INC (@INC contains: t/lib /
usr/opt/perl5/lib/5.6.0/aix /usr/opt/perl5/lib/5.6.0 /usr/opt/perl5/lib/site_perl/5.6.0/aix /usr/opt/perl5/lib
/site_perl/5.6.0 /usr/opt/perl5/lib/site_perl .) at (eval 4) line 3.
Writing Makefile for DBD::Pg

-------------------------------------------------

また、次の段階のmakeコマンドを実行すると最後に以下のようなエラーが表示されストップされてしまいます。

--------------------------------------------------
ld: 0711-317 エラー: 未定義のシンボル: .is_utf8_string
ld: 0711-345 -bloadmap または -bnoquiet オプションを使用して、詳細な情報を得てください。
make: 1254-004 最後のコマンドからのエラー・コードは 8 です。
-------------------------------------------------

投稿日時 - 2005-08-09 18:18:45

QNo.1569684

困ってます

質問者が選んだベストアンサー

>Warning: prerequisite Test::Simple failed to load

Test::Simpleが無いといっています。
Test::Simpleを入れましょう。
(Test::Simpleはあまり依存性がないので簡単に入ると思います)

投稿日時 - 2005-08-11 02:23:04

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問