こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

自分のパソコンでは画像が表示されるのに、他のパソコンだと画像が閉じているのはなぜ?

レンタルサーバーのロリポップでホームページを作りました。ホームページビルダー7でページを作り、そのHTMLをコピーして、ロリポップにあるFTPのページに貼り付け、その後、アップしました。
自分のパソコンでは、画像が表示されているので、画像は表示されていると思っていましたが・・・。
友達の指摘で、すべての画像が閉じているということが最近発覚(>_<)もしかしたら、相手のパソコンのせいもあるのかと思っていたのですが・・・、
ロリポップに確認したところ、やはり、画像は閉じているとのこと。画像のファイルがローカルにあるのが問題だとのこと。
でも、どうして自分のパソコンでは見えているわけ?
ちゃんとホームページのアドレスにアクセスしているのに、ファイルがローカルにあるということはあり得るのですか??? ブラウザの問題ではという人もいます?
本当は、何が原因なのでしょうか?
ホームページの知識はほとんどなく、前途多難です。
どなたか、噛み砕くようにやさしく教えて下さい。
お願いしますm(__)m

投稿日時 - 2005-03-27 23:41:42

QNo.1295257

すぐに回答ほしいです

質問者が選んだベストアンサー

>これは、画像データーのアップロードが出来ていないということですか?

いえ、ビルダー7で作成したHTMLの画像データのパスが間違っています。原因はファイルを保存しないでFTPのページに貼り付けたことかと思います(保存することで相対パスに書き換わります)
また、画像データそのものがアップされていない可能性もあります(FTP時にフォルダは作成しないでいいです)

理解できれば手打ちで修正するところですが、例えば画像が表示されない全てのページに対してビルダー7上で(文字を書き込むなど何でもいい)変更を与えて上書き保存してください。このときHTMLの画像までのパスがC:\Documents and Settings\ユーザー名\ローカルのフォルダ\○○.gifが <img src="/フォルダ名/○○.gif"… のようになっているか確認してください。

なっていれば変更点を削除して再度上書き保存してください。あとはFTPでローカルのファイル全てをアップロードしてください。上書きを聞いてくる(かな?)と思うので全てを上書きしてください。

慣れてきたらビルダーのFTPとかFFFTP
http://www.vector.co.jp/soft/win95/net/se061839.
html
などを利用した方が楽だと思いますよ、がんばって。
http://lolipop.jp/?mode=manual&state=hp&state2=w_ff

参考URL:http://lolipop.jp/?mode=manual&state=start_up&state2=up_load

投稿日時 - 2005-03-28 02:03:54

お礼

回答、ありがとうございます。
原因は、ファイルを保存しないでFTPのページに貼り付けたことだったようです。
結局、ホームページビルダーのFTPを使って、アップロードし直してみました。
FTPの内容を確認してみたら、今まで表示されてなかったファイルがたくさん表示されてました。
今度は、ちゃんと画像が表示されていると思います。
目から、うろこの回答でした。助かりました。

投稿日時 - 2005-03-28 02:53:42

ANo.4

このQ&Aは役に立ちましたか?

2人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.3

#2様への補足にある、
C:\Documents and Settings\ユーザー名\ローカルのフォルダになっています
というのは、HTMLファイルのソースでしょうか?

<img src="C:\Documents and Settings\ユーザー名\ローカルのフォルダ\画像ファイル">
ともしなっていれば、そのHTMLファイルをサーバにアップして、他の人がみたときにも、その見ている人のPCの「C:\Documents and Settings\ユーザー名\ローカルのフォルダ」にある画像ファイルを表示しようとするので、当然のことながら、表示できません。

そのHTMLファイルからの相対パスで書くと、位置関係が間違っていなければそのままアップすれば表示されるようになります。

<img src="./image/image.jpg">
のような形ですね。

ホームページビルダーを使っていないので、方法はわかりかねますが、絶対パスではなく相対パスで記述してくれる設定があるのではないかとおもいます

投稿日時 - 2005-03-28 01:42:41

お礼

回答、ありがとうございました。
仕組みが良く分かりました。結局、ホームページビルダーのFTPを使って、アップロードし直したら、ちゃんと表示されるようになりました。

投稿日時 - 2005-03-28 18:16:43

ANo.2

>ホームページビルダー7でページを作り、そのHTMLをコピーして、ロリポップにあるFTPのページに貼り付け…

で、画像ファイルまでの[パス(どの画像を呼び出すか]が自分のPCのフォルダ(例 C:\Documents and Settings\ユーザー名\ローカルのフォルダ)になっていませんか?
あるいは画像データのアップロードが出来ていないとか。

HPビルダーは使っていないので「どれ」というのは分かりませんが、FTPのツールがあるはずなので全てのファイルを保存(半角英数・スペース不可)して再度アップしてください。

方法はロリポップのマニュアルにあると思いますよ。

投稿日時 - 2005-03-27 23:57:34

お礼

さっそくの回答、ありがとうございます。
C:\Documents and Settings\ユーザー名\ローカルのフォルダになっています。これは、画像データーのアップロードが出来ていないということですか?
ロリポップのFTPのページでアップロードする際、index/sub1/sub2・・・などのフォルダをアップロードした訳ですが・・・、それとは別に画像のフォルダを作って、アップロードするということですか?
そもそも、ホームページのいろはがぜんぜん分かっていないので、アホなことばかり聞いてすみません。

投稿日時 - 2005-03-28 01:02:59

ANo.1

あなたのPCにその画像があっても、
他のPCにはその画像が無いからです。
ちゃんと画像もアップしましたか?

投稿日時 - 2005-03-27 23:52:34

お礼

回答、ありがとうございました。
その通りです。結局、もう一度アップロードし直したら、ちゃんと表示されました。

投稿日時 - 2005-03-28 17:42:43

あなたにオススメの質問