こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

VineLinux3.0でrpm --rebuildができない

タイトルのとおりなんですが、Vine3.0を最小構成でインストールして、xinetの.src.rpmをリビルドしようとしたんですが、rpm --rebuild xinetd*.src.rpmとやってもリビルドできませんでした。
gccはインストールしたんですが、他に何をインストールすればリビルドできるようになるんでしょうか?

投稿日時 - 2004-11-30 15:26:09

QNo.1106585

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

rpmについてですが、rpm --rebuild というオプションは最近のRPMにはないはずです。私も困ったのでわかりますが・・・。その代替がrpmbuildですので、こいつをネットで調べてみてはいかがでしょうか?

投稿日時 - 2005-01-13 23:51:19

ANo.3

オプションが認識されないというと
そのようなファイルやディレクトリはありません
という様なメッセージが出たと言うことですか?

もしそうなら
rpm-build と build-essential をインストールしましょう
--rebuild オプションが使えるようになると思います。

ただNo.2の方が言うようにVine3.0なら rpm より
rpmbuildを使った方が良いとは思います。

投稿日時 - 2004-12-02 23:39:05

rpmbuildは関係ない? (違ったらもうしわけない。自分は2.6なので)

参考URL:http://vinelinux.org/manuals/making-rpm-6.html

投稿日時 - 2004-12-01 06:40:57

ANo.1

ライブラリとかはインストールしていますか?
エラーメッセージに必要なパッケージが表示されると
思うのですが・・・。

投稿日時 - 2004-11-30 16:12:11

お礼

回等ありがとうございます。
エラーとかが出てリビルドできないんではなくて、vine3.0を最小構成でインストールすると開発環境が不十分なせいかrpm --rebuildというオプションが認識されないというか実行できないんです。
前に、vine3.0を入れたときに何かをインストールしたら、rpm --rebuildを実行できるようになったんですが忘れてしまいました。
今の状態でもrpm -ivhなどは実行できます。

投稿日時 - 2004-11-30 17:48:14

あなたにオススメの質問