こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

-広告-

解決済みの質問

L3スイッチの各VLANのPCが外部に出れない

小さいオフィスがあり、L2スイッチがあり、
1つのセグメントで運用しています。(VLAN使っているかは定かではありませんが、
ネットワークは、192.168.10.0/24
このネットワークのゲートウェイ(外部に出るルーター)は
192.168.10.254 になっております。

接続図
インターネットから --> 社内出口ルーター192.168.10.254 --> 社内DELL
L2スイッチ -> (今回導入予定のL3スイッチ)


一本ケーブルが来ており、これを
ノンインテリジェントのS2スイッチを繋ぐと、その配下にあるポートには、
ネットワークの接続が可能となります。

今回は、 cisco WS-C3550-24 スイッチを一台準備し、これを社内LANに接続したいと考えております。
(上位スイッチ、または、出口ルーターについては、設定をいじれません)
このスイッチ上に、vlan を3つ作り、
それぞれ、
Vlan11192.168.1.0 /24
Vlan2192.168.2.0 / 24
Vlan10192.168.10.0 /24

以下 show ip route
*********************
Gateway of last resort is 192.168.10.254 to network 0.0.0.0

C 192.168.10.0/24 is directly connected, Vlan10
C 192.168.1.0/24 is directly connected, Vlan11
C 192.168.2.0/24 is directly connected, Vlan2
S* 0.0.0.0/0 [1/0] via 192.168.10.254
*****
xxxxx #
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/1, Gi0/2
2 vlan_2 active Fa0/6, Fa0/7, Fa0/8
3 vlan_3 active Fa0/9, Fa0/10
10 VLAN0010 active Fa0/23, Fa0/24
11 vlan_1 active Fa0/1, Fa0/2, Fa0/3, Fa0/4, Fa0/5
***************:
*show configration

ip routing

interface FastEthernet0/1
switchport access vlan 11
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 11
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 11
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 11
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 11
switchport mode access

interface FastEthernet0/6
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 2
switchport mode access


interface FastEthernet0/24
switchport access vlan 10
switchport mode access

interface Vlan10
ip address 192.168.10.195 255.255.255.0

interface Vlan11
ip address 192.168.1.254 255.255.255.0

interface Vlan2
ip address 192.168.2.254 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.10.254

●やりたい事

社内のケーブルをこのスイッチ ポート24に指します。
vlan 2 の下にFa0/6, Fa0/7, Fa0/8ポートから、3台のPCを接続しています。
これらのPCのゲートウェイは、192.168.2.254 としています。
vlan 3 の下にはFa0/9, Fa0/10 ポートを経由してPCを接続しています
これらのPC のゲートウェイは、192.168.3.254 としています。

これらのPCが新たに、設置されたこのL3スイッチのVLANから、外部の
インターネットに接続できるようにすることです。
L3スイッチは、そのポート24を経由して、外部に接続できるのではないか
と考えています。
*********************
●困っている事

vlan 2 または、vlan 3 配下のPCから、それぞれのpc に対してping は可能である
vlan 2 または、vlan 3 配下のPCから、外部へのインターネット接続が不可である。
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

シスコスイッチに、telnet で入り、そこからは、192.168.10.254 等、192.168.10.0/24
のネットワークに疎通可能である。
また、外部へのping も可能である。

ルーティングテーブルを見ると、192.168.10.0のネットワークは、接続されている
と定義されていますが、
C 192.168.10.0/24 is directly connected, Vlan10

これではだめなのでしょうか?
192.168.10.254 の行き方は、cisco WS-C3550-24が
知っていると思うのですが。。。

なぜ、vlan2 または、vlan 1 配下のPCから192.168.10.254
にping が飛ばないのでしょうか?

投稿日時 - 2015-09-01 19:44:27

QNo.9040362

すぐに回答ほしいです

質問者が選んだベストアンサー

こんにちは。hirasakuです。

原因は出口ルータにVLAN1とVLAN2の戻りのルートがないからです。
出口ルータの設定ができないということであれば不可能では。

設定変更ができるのであれば出口ルータに
192.168.1.0/24 と 192.168.2.0/24 を知ってるのは 192.168.10.195(CatalystのIP)です
というルートを追加しましょう。

では。

投稿日時 - 2015-09-02 09:40:44

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

-広告-
-広告-

回答(1)

-広告-
-広告-
-広告-
-広告-