こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

-広告-

解決済みの質問

【Javaの開発環境Eclipse】

↓次の指示に従って、eclipse KeplerとJavaのインストールを試みています。

《指示》
You will need the following tools:
•Java 7, if using Java 8 compiler please set to 7 compatibility
•Eclipse for RCP and RAP Developers. We recommend to use Eclipse Kepler (Version 4.3)
•SVN Client (see next step for details)

しかしながら、eclipsec.exeのファイルから起動する際、
↓以下のような警告が出ます。

《警告》
Java HotSpot(TM) Client VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0

JavaはJava 7を使用したいのですが、
(1)上記の警告にどのように対処すべきか、
(2)Java 8からJava 7へのcompatibilityをどう適応させれば良いのか、
教えて頂けないでしょうか...。

なお、(2)に関してはJavaのページを検索してみましたが、
具体的な対処方法が分からず、困っています。
http://www.oracle.com/technetwork/java/javase/compatibility-137541....

どなたか詳しい方が居られましたら、ご教授願います。
よろしくお願い致します。

投稿日時 - 2015-08-08 16:15:57

QNo.9026556

困ってます

質問者が選んだベストアンサー

内容通りですが、「MaxPermSize」オプションは除外&無視されて、Java8からはオプションそのものが削除されてしまった。

javaの環境変数やeclipseのiniファイルなど「MaxPermSize」が書かれてる箇所を削除すれば良いのでは?と思います。

投稿日時 - 2015-08-11 15:08:55

お礼

回答頂きありがとうございます!
はい、MaxPermSizeについて検索してみると、
削除するようなことが書いてあり、
何とか起動させることができるようになりました!
ありがとうございました。

投稿日時 - 2015-08-17 09:55:55

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

-広告-
-広告-

回答(1)

-広告-
-広告-

あなたにオススメの質問

-広告-
-広告-