こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

-広告-

締切り済みの質問

MiracleLinux4.0の各種アップデートが…

なさけないエンジニアのCIA0010でございます。
タイトルにも書かせて頂きましたが、Miracleの4.0で
シンクライアント用のファイルサーバを構築しているのですが
以下の問題をかかえ前に進めない状態となってしまいました。

目次:
(1)カーネルのアップデート
(2)サービスパックのアップデート
(3)iSCSIを利用するためのカーネル再構築

(1)カーネルのアップデート
現在のカーネルバージョンは Kernel-2.6.9-11.19AX
となっておりますが、最新のKernelへアップしたいです。
理由:現在のカーネルバージョンのままDELLのPowerEdge2950へ
インストールしますと
---------------------------------------------------------
1. ディスクを自動認識しないため、ドライバディスクが必要です。
・ LSI Logic MegaRAID SASコントローラー対応ドライバ
2. NICの自動検出ができないため、カーネルアップデートが必要です。
・ 2.6.9-34.21AX以後のカーネルを利用してください。
---------------------------------------------------------
の問題点がでるためです。
「1.」はサイトを調べ解決したのですが、「2.」を実施するにあたり、
私の心のパトランプが黄色点灯したのです。

それは、

(2)サービスパックのアップデート
現在はSP1ですが、SP2でないと、2TB越えのディスク領域を
使用できないためです。

(3)iSCSIを利用するためのカーネル再構築
(2)で記載しました2TB越えのストレージはiSCSIで接続されているため
です。。。

アップデートの順番をどうすれば良いかが…

(2)→(1)→(3)が良いのか、
(1)→(2)→(3)が良いのかがわからず、パニックになっております。。。

くどくどと書き恐縮ではございますが、
どうか小職に救いの手を差し伸べて頂きたく存じます。

バージョン等の情報は以下の通りです。
OS:MIRACLE LINUX V4.0(SP1) - Asianux Inside for x86-64
Kernel:2.6.9-11.19AX
H/W:DELL PowerEdge2950


以上となります。どうか宜しくお願い致します。

投稿日時 - 2008-01-25 00:36:58

QNo.3711182

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

4人が「このQ&Aが役に立った」と投票しています

-広告-
-広告-

回答(2)

ANo.2

そもそも、SP2って新規インストール用のISOが配られているのですから
それでまずはインストールするってのはダメなんですか?
正規品であればダウンロード可能なはずですよ。

投稿日時 - 2008-01-26 17:45:48

お礼

anights 様

ご回答いただきまして、ありがとうございます。
お礼を申し上げるのが遅くなり申し訳ございません。

anights 様からのアドバイス頂いた内容にございますように、
SP2を入れた後にカーネルをアップデートいたしました。

今は ADとsambaにやられております。。。
# smb.conf の設定で valid users = hoge,@hoge_hoge
# と設定する際、 @hoge_hoge グループの作成はWinServer側で
# 設定するのか、Linux側でグループ作成するのか等で悩んでます。
# Linux ではグループ作成してみたのですが…ダメでした。。

この度はご回答頂きまして、本当にありがとうございました。
それでは、失礼致します。

投稿日時 - 2008-01-30 23:47:51

-広告-

ANo.1

確かに・・・第三者の僕のランプも点灯しそうです・・・

念のためAsianux3を見ると、PE2950は普通に○が付いています。
ということは、カーネルをアップデートするとSASを認識するかもしれませんね。

カーネルは一つまえに戻すことが出来ますので、エイや!っと最新を入れて
みるのはいかがでしょう。

(1)でカーネルを最新にしてSASの認識状況を確認
(2)でカーネル以外をアップデート
(3)を実行する

まあ、1->2->3ということですが・・

投稿日時 - 2008-01-25 02:19:52

お礼

dyna_1550様

ご回答いただきまして、ありがとうございます。
本当に感動です!
(以前、別の質問を投稿した際、何方からもご回答がなかったので…^^;

その後についてですが、SP2を入れカーネルアップデートし、
今は。。。。AD と samba の間でもがいております。

短文で恐縮ですが、心よりお礼申し上げます。

投稿日時 - 2008-01-30 23:34:36

-広告-
-広告-

あなたにオススメの質問

-広告-
-広告-